@@ -1,41 +1,30 @@ | |||
-# $NetBSD: Makefile,v 1. | +# $NetBSD: Makefile,v 1.129 2024/12/12 13:15:47 fox Exp $ | ||
DISTNAME= fasttracker2-1.95 | DISTNAME= fasttracker2-1.95 | ||
+PKGREVISION= 1 | |||
CATEGORIES= audio | CATEGORIES= audio | ||
MASTER_SITES= ${MASTER_SITE_GITH | MASTER_SITES= ${MASTER_SITE_GITH | ||
GITHUB_PROJECT= ft2-clone | GITHUB_PROJECT= ft2-clone | ||
GITHUB_TAG= v${PKGVERSION_NOREV | GITHUB_TAG= v${PKGVERSION_NOREV | ||
-EXTRACT_USING= bsdtar | |||
MAINTAINER= fox@NetBSD.org | MAINTAINER= fox@NetBSD.org | ||
HOMEPAGE= https://16-bits.org/ | HOMEPAGE= https://16-bits.org/ | ||
COMMENT= Portable Fasttracker II clone in C using SDL 2 | COMMENT= Portable Fasttracker II clone in C using SDL 2 | ||
LICENSE= modified-bsd AND cc-by-nc-sa-v4.0-license | LICENSE= modified-bsd AND cc-by-nc-sa-v4.0-license | ||
-USE_LANGUAGES= | +USE_LANGUAGES= c c++ | ||
USE_TOOLS+= pkg-config | USE_TOOLS+= pkg-config | ||
+FORCE_C_STD= gnu99 | |||
+ | |||
CMAKE_CONFIGURE_ | CMAKE_CONFIGURE_ | ||
LDFLAGS+= ${BUILDLINK_LDADD.iconv} | LDFLAGS+= ${BUILDLINK_LDADD.iconv} | ||
-TOOL_DEPENDS+= icoutils-[0-9]*:../../graphics/icoutils | |||
- | |||
-ICON_SIZES= 16 24 32 48 64 128 256 | |||
- | |||
INSTALLATION_DIR | INSTALLATION_DIR | ||
INSTALLATION_DIR | INSTALLATION_DIR | ||
INSTALLATION_DIR | INSTALLATION_DIR | ||
-.for s in ${ICON_SIZES} | +INSTALLATION_DIR | ||
-INSTALLATION_DIR | |||
-.endfor | |||
- | |||
-pre-configure: | |||
-.for s in ${ICON_SIZES} | |||
- cd ${WRKSRC} && ${PREFIX}/bin/icotool \ | |||
- -w ${s} -h ${s} -x -o ${s}.png \ | |||
- src/gfxdata/icon/ft2-clone.ico | |||
-.endfor | |||
do-install: | do-install: | ||
${INSTALL_PROGRAM} ${WRKSRC}/release/other/ft2-clone \ | ${INSTALL_PROGRAM} ${WRKSRC}/release/other/ft2-clone \ | ||
@@ -44,20 +33,18 @@ | |||
${DESTDIR}${PREFIX}/share/applications | ${DESTDIR}${PREFIX}/share/applications | ||
${INSTALL_DATA} ${FILESDIR}/fasttracker2.appdata.xml \ | ${INSTALL_DATA} ${FILESDIR}/fasttracker2.appdata.xml \ | ||
${DESTDIR}${PREFIX}/share/appdata | ${DESTDIR}${PREFIX}/share/appdata | ||
-.for s in ${ICON_SIZES} | + ${INSTALL_DATA} ${WRKSRC}/src/gfxdata/icon/ft2-clone.png \ | ||
- ${INSTALL_DATA} ${WRKSRC}/${s}.png \ | + ${DESTDIR}${PREFIX}/share/pixmaps/fasttracker2.png | ||
- ${DESTDIR}${PREFIX}/share/icons/hicolor/${s}x${s}/apps/fasttracker2.png | |||
-.endfor | |||
.include "../../mk/bsd.prefs.mk" | .include "../../mk/bsd.prefs.mk" | ||
-.if ${OPSYS} | +.if ${OPSYS} == "Linux" | ||
-BUILDLINK_TRANSF | |||
-.else | |||
. include "../../audio/alsa-lib/buildlink3.mk" | . include "../../audio/alsa-lib/buildlink3.mk" | ||
.endif | .endif | ||
.include "../../audio/flac/buildlink3.mk" | .include "../../audio/flac/buildlink3.mk" | ||
.include "../../converters/libiconv/buildlink3.mk" | .include "../../converters/libiconv/buildlink3.mk" | ||
-.include "../../graphics/hicolor-icon-theme/buildlink3.mk" | |||
.include "../../devel/SDL2/buildlink3.mk" | .include "../../devel/SDL2/buildlink3.mk" | ||
.include "../../devel/cmake/build.mk" | .include "../../devel/cmake/build.mk" | ||
+.include "../../sysutils/desktop-file-utils/desktopdb.mk" | |||
+PTHREAD_OPTS?= require | |||
+.include "../../mk/pthread.buildlink3.mk" | |||
.include "../../mk/bsd.pkg.mk" | .include "../../mk/bsd.pkg.mk" |
@@ -2,10 +2,4 @@ | |||
bin/fasttracker2 | bin/fasttracker2 | ||
share/appdata/fasttracker2.appdata.xml | share/appdata/fasttracker2.appdata.xml | ||
share/applications/fasttracker2.desktop | share/applications/fasttracker2.desktop | ||
-share/ | +share/pixmaps/fasttracker2.png | ||
-share/icons/hicolor/16x16/apps/fasttracker2.png | |||
-share/icons/hicolor/24x24/apps/fasttracker2.png | |||
-share/icons/hicolor/256x256/apps/fasttracker2.png | |||
-share/icons/hicolor/32x32/apps/fasttracker2.png | |||
-share/icons/hicolor/48x48/apps/fasttracker2.png | |||
-share/icons/hicolor/64x64/apps/fasttracker2.png |
@@ -1,6 +1,7 @@ | |||
-$NetBSD: distinfo,v 1. | +$NetBSD: distinfo,v 1.115 2024/12/12 13:15:47 fox Exp $ | ||
BLAKE2s (fasttracker2-1.95.tar.gz) = 1ce4b73406c500bc | BLAKE2s (fasttracker2-1.95.tar.gz) = 1ce4b73406c500bc | ||
SHA512 (fasttracker2-1.95.tar.gz) = c8ccda7dbd866bdd | SHA512 (fasttracker2-1.95.tar.gz) = c8ccda7dbd866bdd | ||
Size (fasttracker2-1.95.tar.gz) = 5229238 bytes | Size (fasttracker2-1.95.tar.gz) = 5229238 bytes | ||
SHA1 (patch-CMakeLists.txt) = 95b3f8e836a98d2c | SHA1 (patch-CMakeLists.txt) = 95b3f8e836a98d2c | ||
@@ -4,3 +4,4 @@ | |||
SHA512 (fasttracker2-1.95.tar.gz) = c8ccda7dbd866bdd | SHA512 (fasttracker2-1.95.tar.gz) = c8ccda7dbd866bdd | ||
Size (fasttracker2-1.95.tar.gz) = 5229238 bytes | Size (fasttracker2-1.95.tar.gz) = 5229238 bytes | ||
SHA1 (patch-CMakeLists.txt) = 95b3f8e836a98d2c | SHA1 (patch-CMakeLists.txt) = 95b3f8e836a98d2c | ||
+SHA1 (patch-src_ft2__diskop.c) = 900e72818483db2f |
@@ -1,75 +1,17 @@ | |||
-$NetBSD: patch-src_ft2__diskop.c,v 1.6 2019/08/02 16:54:10 fox Exp $ | +$NetBSD$ | ||
-1. Added <sys/types.h> and <sys/stat.h> before the include of | +Fix build with older glibc which does not like fts.h being included | ||
- <fts.h>. While fts(3) is not yet standardized by POSIX, NetBSD | +when _FILE_OFFSET_BIT | ||
- contains an implementation that was expected to comply with the | |||
- eventual standard, and fts(3) on NetBSD documents that the above | |||
- includes are required. Resolves build failure on netbsd-8. | |||
- | |||
-2. Added SunOS / SmartOS compatibility. | |||
-Note: Contacted the upstream author regarding the patch and awaiting a | +--- src/ft2_diskop.c.orig 2025-03-31 21:27:31.508418094 +0000 | ||
-reply. https://16-bits.org/ft2.php | |||
- | |||
---- src/ft2_diskop.c.orig 2019-06-20 21:20:34.000000000 +0000 | |||
+++ src/ft2_diskop.c | +++ src/ft2_diskop.c | ||
-@@ - | +@@ -3,7 +3,9 @@ | ||
- #include | + #include <crtdbg.h> | ||
- #include <shlobj.h> // SHGetFolderPathW | |||
- #else | |||
-+#include <sys/types.h> | |||
-+#include <sys/stat.h> | |||
- #include <fts.h> // for fts_open() and stuff in recursiveDelete() | |||
- #include <unistd.h> | |||
- #include <dirent.h> | |||
-@@ -1395,6 +1397,10 @@ static int8_t findFirst(DirRec *searchRe | |||
- int64_t fSize; | |||
#endif | #endif | ||
-+#if defined(__sun) || defined(sun) | ++#ifndef __linux | ||
-+ struct stat s; | + #define _FILE_OFFSET_BIT | ||
+#endif | +#endif | ||
-+ | |||
- searchRec->nameU = NULL; // this one must be initialized | |||
- | |||
- #ifdef _WIN32 | |||
-@@ -1422,9 +1428,19 @@ static int8_t findFirst(DirRec *searchRe | |||
- return LFF_SKIP; | |||
- searchRec->filesize = 0; | + #include <stdint.h> | ||
-+ | + #include <stdio.h> | ||
-+#if defined(__sun) || defined(sun) | |||
-+ stat(fData->d_name, &s); | |||
-+ searchRec->isDir = (s.st_mode != S_IFDIR) ? true : false; | |||
-+#else | |||
- searchRec->isDir = (fData->d_type == DT_DIR) ? true : false; | |||
-+#endif | |||
- | |||
-+#if defined(__sun) || defined(sun) | |||
-+ if (s.st_mode == S_IFLNK) | |||
-+#else | |||
- if (fData->d_type == DT_UNKNOWN || fData->d_type == DT_LNK) | |||
-+#endif | |||
- { | |||
- if (stat(fData->d_name, &st) == 0) | |||
- { | |||
-@@ -1488,9 +1504,19 @@ static int8_t findNext(DirRec *searchRec | |||
- return LFF_SKIP; | |||
- | |||
- searchRec->filesize = 0; | |||
-+ | |||
-+#if defined(__sun) || defined(sun) | |||
-+ stat(fData->d_name, &s); | |||
-+ searchRec->isDir = (s.st_mode != S_IFDIR) ? true : false; | |||
-+#else | |||
- searchRec->isDir = (fData->d_type == DT_DIR) ? true : false; | |||
-+#endif | |||
- | |||
-+#if defined(__sun) || defined(sun) | |||
-+ if (s.st_mode == S_IFLNK) | |||
-+#else | |||
- if (fData->d_type == DT_UNKNOWN || fData->d_type == DT_LNK) | |||
-+#endif | |||
- { | |||
- if (stat(fData->d_name, &st) == 0) | |||
- { |