OpenBSD/ports sJjq7WO — geo/traccar Makefile distinfo, geo/traccar/pkg PLIST

   Update to 6.17.0

   OK sthen@
VersionDeltaFile
1.46+410-393geo/traccar/pkg/PLIST
1.42+2-2geo/traccar/distinfo
1.56+1-1geo/traccar/Makefile
+413-3963 files

OpenBSD/ports hDnkHjd — textproc/py-xmlschema distinfo Makefile, textproc/py-xmlschema/pkg PLIST

   update to py3-xmlschema-4.3.2
VersionDeltaFile
1.10+98-21textproc/py-xmlschema/pkg/PLIST
1.19+2-3textproc/py-xmlschema/Makefile
1.13+2-2textproc/py-xmlschema/distinfo
+102-263 files

OpenBSD/ports ldAy46i — textproc/py-elementpath Makefile distinfo, textproc/py-elementpath/pkg PLIST

   update to py3-elementpath-5.1.4
VersionDeltaFile
1.10+46-9textproc/py-elementpath/pkg/PLIST
1.14+2-2textproc/py-elementpath/distinfo
1.20+1-2textproc/py-elementpath/Makefile
+49-133 files

OpenBSD/ports Tlao8Yf — security/py-cryptodome Makefile

   update comment
VersionDeltaFile
1.55+8-4security/py-cryptodome/Makefile
+8-41 files

OpenBSD/ports rGe5rh6 — security/py-cryptodome distinfo Makefile, security/py-cryptodome/pkg PLIST

   update to py3-cryptodome-4.3.0

   now uses ARMv8 Cryptography Extensions on aarch64 and has various other
   speed increases: https://www.pycryptodome.org/src/changelog#november-2026
VersionDeltaFile
1.54+9-7security/py-cryptodome/Makefile
1.34+6-0security/py-cryptodome/pkg/PLIST
1.31+2-2security/py-cryptodome/distinfo
+17-93 files

OpenBSD/ports WlQxTl9 — audio/schismtracker Makefile distinfo

   Update schismtracker to 20261102.
VersionDeltaFile
1.49+2-2audio/schismtracker/distinfo
1.67+1-1audio/schismtracker/Makefile
+3-32 files

OpenBSD/src 9lBO2jp — usr.sbin/rpki-client cert.c

   rpki-client: use strncmp() after x509_location()

   Now that the protocol (always expected to be https:// or rsync://) is
   normalized, we can do a simpler check.

   Prompted by a report by Ties de Kock

   ok claudio
VersionDeltaFile
1.252+7-7usr.sbin/rpki-client/cert.c
+7-71 files

OpenBSD/src eWHjI2M — usr.sbin/rpki-client x509.c

   rpki-client: reject short URIs in x509_location()

   Reject URIs not long enough to hold https:// or rsync://. While "a:///b/c"
   is in principle legal, this isn't plausibly a valid URI that should occur
   in the wild. Reject certs containing this.

   pointed out by/ok claudio
VersionDeltaFile
1.138+2-2usr.sbin/rpki-client/x509.c
+2-21 files

OpenBSD/src zqWq8OY — usr.sbin/rpki-client x509.c

   rpki-client: normalize known URI schemes in x509_location()

   RFC 3986 was written under full influence of the robustness principle,
   necessarily making all code handling URIs complicated and fragile. This
   is further exacerbated by RFC 5280 explicitly mentioning that scheme and
   host part of a URI are case-insensitive (for SAN, not explicitly for a
   URI accessLocation, but that seems implied).

   The schemes explicitly specified by RFC 6487 and friends are rsync and
   https and that's the only ones the callers do anything with. Normalize
   these to be lower case and accept other schemes (and currently no scheme)
   for simplicity. This avoids hitting an errx() in queue_add_from_cert().

   Reported by Ties de Kock

   ok claudio
VersionDeltaFile
1.137+27-2usr.sbin/rpki-client/x509.c
+27-21 files

OpenBSD/ports ejCnYnR — devel/py-pip Makefile distinfo, devel/py-pip/pkg PLIST

   update to py3-pip-26.3
VersionDeltaFile
1.44+115-6devel/py-pip/pkg/PLIST
1.53+2-2devel/py-pip/distinfo
1.87+1-1devel/py-pip/Makefile
+118-93 files

OpenBSD/ports jiIzbao — www/nghttp2 distinfo Makefile, www/nghttp2/patches patch-Makefile_in

   update to nghttp2-1.71.0
VersionDeltaFile
1.73+2-2www/nghttp2/distinfo
1.82+2-2www/nghttp2/Makefile
1.21+1-1www/nghttp2/patches/patch-Makefile_in
+5-53 files

OpenBSD/ports eV2QR04 — security/py-cryptodome-test-vectors Makefile distinfo, security/py-cryptodome-test-vectors/pkg PLIST

   update to py3-cryptodome-test-vectors-1.0.28
VersionDeltaFile
1.11+2-2security/py-cryptodome-test-vectors/distinfo
1.15+3-0security/py-cryptodome-test-vectors/pkg/PLIST
1.16+1-1security/py-cryptodome-test-vectors/Makefile
+6-33 files

OpenBSD/src lOvmOu2 — usr.sbin/rpki-client http.c

   Convert some assert() to simple http request failures with warn message.

   In theory the asserts placed should never be hit since for example at the
   end of a request no outstanding data should be left in the buffers. In
   practice those asserts did trigger too often. Bad servers could remotly
   trigger them and so it is clear that these failures are not assertions.

   Triggered by a report by Ties de Kock
   OK tb@
VersionDeltaFile
1.111+25-7usr.sbin/rpki-client/http.c
+25-71 files

OpenBSD/ports 8ryHr9N — www/nghttp3 distinfo Makefile

   Update to nghttp3 1.19.0

   https://github.com/ngtcp2/nghttp3/releases/tag/v1.19.0
VersionDeltaFile
1.27+2-2www/nghttp3/distinfo
1.31+2-2www/nghttp3/Makefile
+4-42 files

OpenBSD/ports XHUJ3J7 — net/ngtcp2 distinfo Makefile

   Update to ngtcp2 1.26.0

   https://github.com/ngtcp2/ngtcp2/releases/tag/v1.26.0
VersionDeltaFile
1.41+2-2net/ngtcp2/distinfo
1.44+2-2net/ngtcp2/Makefile
+4-42 files

OpenBSD/ports Fs6q8oy — devel/zizmor Makefile crates.inc

   Update to zizmor 1.32.0

   https://github.com/zizmorcore/zizmor/releases/tag/v1.32.0
VersionDeltaFile
1.13+34-30devel/zizmor/distinfo
1.11+16-14devel/zizmor/crates.inc
1.16+1-5devel/zizmor/Makefile
+51-493 files

OpenBSD/src ruvxThZ — sys/dev/usb if_rum.c

   Reject receive transfers whose descriptor frame length exceeds the data
   actually transferred.  The descriptor carries a 12-bit frame length and
   the chip accepts frames up to 4095 bytes, but a receive transfer only has
   MCLBYTES minus the descriptor for frame data.

   Trusting the descriptor produced an mbuf extending past its cluster.
   A fragmented IPv4 datagram then carried it into m_cat(), where a default
   kernel panics on a DIAGNOSTIC assertion.

   Report and diff from Acts1631.

   ok miod@ claudio@ kettenis@
VersionDeltaFile
1.130+10-3sys/dev/usb/if_rum.c
+10-31 files

OpenBSD/ports NdNIqoA — devel/dtools Makefile

   devel/dtools: switch to gdc
VersionDeltaFile
1.10+3-11devel/dtools/Makefile
+3-111 files

OpenBSD/ports UsZTice — devel/dub/patches patch-scripts_man_gen_man_d

   devel/dub: add missed patch
VersionDeltaFile
1.1+11-0devel/dub/patches/patch-scripts_man_gen_man_d
+11-01 files

OpenBSD/ports 7VUXWT2 — devel/dub Makefile

   devel/dub: use LLD and fix build on PowerPC

   Brad Smith pointed that LLD can be used now
VersionDeltaFile
1.14+5-3devel/dub/Makefile
+5-31 files

OpenBSD/src rqgtOTO — sys/arch/macppc/include vmparam.h

   sys/macppc: increase MAXDSIZ to 3Gb

   OK: kettenis@
VersionDeltaFile
1.34+2-2sys/arch/macppc/include/vmparam.h
+2-21 files

OpenBSD/ports ZWL5RLl — net/tailscale Makefile modules.inc

   Update to tailscale-1.104.4

   From Adriano Barbosa (maintainer)
VersionDeltaFile
1.72+206-194net/tailscale/distinfo
1.44+73-67net/tailscale/modules.inc
1.75+1-1net/tailscale/Makefile
+280-2623 files

OpenBSD/ports JkzhXEr — audio/navidrome Makefile modules.inc, audio/navidrome/pkg PLIST

   Update to navidrome-0.64.2

   From Igor Zornik (maintainer)
VersionDeltaFile
1.12+350-350audio/navidrome/distinfo
1.13+103-107audio/navidrome/modules.inc
1.23+24-14audio/navidrome/Makefile
1.6+2-0audio/navidrome/pkg/PLIST
+479-4714 files

OpenBSD/ports FMoFJBi — devel/cargo-c Makefile crates.inc

   Update to cargo-c 0.10.26

   https://github.com/lu-zero/cargo-c/releases/tag/v0.10.26
VersionDeltaFile
1.19+170-170devel/cargo-c/distinfo
1.20+83-83devel/cargo-c/crates.inc
1.19+1-1devel/cargo-c/Makefile
+254-2543 files

OpenBSD/ports iCPexMu — misc/llama.cpp distinfo Makefile

   misc/llama.cpp: update to 0.8.0

   Replaced unknown commit diff by OpenBSD, suggested by Mikolaj Kucharski
VersionDeltaFile
1.37+6-5misc/llama.cpp/Makefile
1.30+4-4misc/llama.cpp/distinfo
+10-92 files

OpenBSD/ports f4Dm2Hz — devel/libggml distinfo Makefile, devel/libggml/patches patch-src_ggml-cpu_ops_cpp patch-src_ggml-cpu_ggml-cpu_c

   devel/libggml: update to 0.26.0
VersionDeltaFile
1.3+13-13devel/libggml/patches/patch-src_ggml-cpu_vec_h
1.2+8-8devel/libggml/patches/patch-src_ggml-cpu_vec_cpp
1.4+4-4devel/libggml/patches/patch-src_ggml-cpu_ggml-cpu_c
1.31+3-3devel/libggml/Makefile
1.5+2-2devel/libggml/patches/patch-src_ggml-cpu_ops_cpp
1.27+2-2devel/libggml/distinfo
+32-321 files not shown
+33-337 files

OpenBSD/ports d6LZ9KD — math/z3 distinfo Makefile

   math/z3: update to 5.3.3
VersionDeltaFile
1.30+2-2math/z3/distinfo
1.53+2-2math/z3/Makefile
+4-42 files

OpenBSD/ports WcxoXfi — net/hurl Makefile crates.inc

   Update to hurl 8.1.0.
VersionDeltaFile
1.7+206-266net/hurl/distinfo
1.7+102-132net/hurl/crates.inc
1.10+1-3net/hurl/Makefile
+309-4013 files

OpenBSD/src cprcdiT — sys/arch/sparc64/sparc64 trap.c

   Remove support for "fpu disabled" traps in the kernel. This used to be needed
   to allow VIS instructions to be used in the kernel, but the last use of them
   was removed in 2003.

   ok claudio@
VersionDeltaFile
1.132+1-41sys/arch/sparc64/sparc64/trap.c
+1-411 files

OpenBSD/ports 7TIs5Ue — archivers/zpaqfranz Makefile distinfo

   archivers/zpaqfranz: update to 65.17

   From maintainer tux0r, thanks!
VersionDeltaFile
1.44+2-2archivers/zpaqfranz/distinfo
1.48+1-1archivers/zpaqfranz/Makefile
+3-32 files